Seems this is taking a little longer than planned to rectify, for anyone still having issues with Firefox then Blackcats member Amiga1200 has posted this useful workaround to manually add in our self signed certificate as an exception, meaning you can use Firefox to access our site without the security risk page occurring:

1) Type about:config in the firefox address bar
2) Change "browser.xul.error_pages.expert_bad_cert" in about:config to True. This will give you additional certificate options as well as the (non-functional) ability to add exceptions.
3) Click "Add Exception.." -> Get Certificate -> Export. Save the certificate somewhere.
4) Go to tools -> options -> advanced -> Certificates and click view certificates
5) Import the certificate you saved off earlier.
6) Scroll through the list until you see Blackcats-Games
7) Click Edit Trust and check all three check boxes.
8) Restart Firefox.

If you are having issues with Firefox then I recommend you try the above, it takes 2 minutes to do, and you can give feedback in the related forum thread.