There seems to be an issue with emails being received from TranceTraffic by certain email providers such as Gmail.

Please make sure to add 'noreply@trancetraffic.com' to your email's safe list.

In Gmail:
Settings > Filters > 'Create a new filter' > "From: noreply@trancetraffic.com" > 'Create filter with this search' > ' Never send it to Spam' > Create Filter.

When sending out invites to people, please ask them to do the same otherwise they may not receive the required emails to confirm their account.